Remote is not releasing the shutter (Not taking a picture)

Troubleshooting:
 
  • Make sure the connection to the camera from the receiver is properly connected, press and hold the power button on the receiver until the red LED comes on, simply pressing the power button will not turn it on.
    • Is the receiver on?
  • When the remote is turned on a blue LED light should come on the remote and the receiver to indicate power.
    • Does the receiver indicate power to the remote?
  • Be sure the dip switches are in the same sequence on both the remote and the receiver.
    • Are the white switches in the same position on the remote and receiver?
  • The camera may have to be set into remote shooting mode in the settings of your camera. Consult the manual of the camera to see if this is an option.
    • Does your camera have a remote shooting mode, does the remote work if enabled?
  • Make sure the shutter release button is being fully pressed down so that the LED glows red.
    • Does pressing and holding down the button on the remote release the shutter?
  • Remove any obstructions that may be in the way of the receiver and the remote.
    • Is there a clear line of sight between the remote and the receiver?
  • Test the receiver by pressing the shutter release button, if the shutter releases when pressing the button the receiver the remote may be defective.
    • Does pressing the shutter button on the receiver release the shutter?

Please contact customer service if the troubleshooting above does not solve the problem.

Add Feedback